Scheduled for 07 30 2025 at 4:30 AM – 6:30 AM
Affects
Email & SMS
Under maintenance from 4:30 AM to 6:30 AM
Outbound Email
Under maintenance from 4:30 AM to 6:30 AM
Completed
07 30 2025 at 6:30 AMCompleted
07 30 2025 at 6:30 AMMaintenance is now in progress
In progress
07 30 2025 at 4:30 AMIn progress
07 30 2025 at 4:30 AMMaintenance is now in progress
Planned
07 30 2025 at 4:30 AMPlanned
07 30 2025 at 4:30 AMOn 7th October between 05:30 and 07:30 (BST), bulk email sending and template editing will be temporarily unavailable while we release our new email editor to all customers.
Automated emails, such as those triggered by lead actions and workflows, will continue to work as normal. However, users may not be able to send emails manually during this time.
All other services will remain available, and full functionality will be restored once the maintenance is complete. No action is required on your part.