Problem loading activity feed on a lead
Incident Report for FLG
Resolved
This incident has been resolved.
Posted 10 days ago. Aug 07, 2019 - 15:43 BST
Investigating
We have received reports that the activity feed on a lead is not loading correctly when an 'All items' filter is set. We are currently investigating and will update as soon as we can.
Posted 10 days ago. Aug 07, 2019 - 14:41 BST
This incident affected: FLG.