Unexpected emails and text messages sent in error
Incident Report for FLG
Postmortem

The impact of this incident was variable, with a handful of customers affected more than others, whilst the large majority of our customers were unaffected. Within 2 working days of the issue being reported, we contacted all customers affected and worked more closely with the few most affected by providing additional details and supporting further enquiries.

From the lessons learned from this incident, we have improved our Incident Management Process and implemented additional checks to prevent a recurrence of this issue.

We would like to take the time to appologise for any disruption caused and to thank all our customers for their patience and positive response to our assistance.

Posted Jan 25, 2023 - 14:41 GMT

Resolved
We have had reports of emails and text messages being erroneously sent for some leads between the hours of 7 PM on 18/01/2023 and 08:40 AM today (19/01/2023).

This issue has now been resolved so no further texts or emails will be sent. Further details about the impact will be shared in the coming days.
Posted Jan 18, 2023 - 19:00 GMT