Our main contact number is currently unreachable
Incident Report for FLG
Resolved
The main contact number is now working.
Posted May 19, 2022 - 12:26 BST
Investigating
FLG's main contact number (01282 798 545) is currently unreachable. This is being looked into.

If you need to contact our team the following temporary numbers can be used:
Support - 01282 216314
Sales - 01282 216310
Payments - 01282 216309

You can also reach out for support by emailing support@getflg.com
Posted May 19, 2022 - 10:12 BST
This incident affected: Other.