Issue generating sub leads
Incident Report for FLG
Resolved
The issue has now been resolved.

The problem was introduced by a code change which went live at 00.00 today when a scheduled restart introduced new code. The problem was fixed at 18.02 today.

The problem affected a small numbers of customers using sub leads and we will be contacting each of them with more information.

The sub lead creation process correctly generated a sub lead reference but this was not shown in the user interface and was missing in subsequent steps. Customers referring sub leads to partners using internet delivery and using other webhooks may have been affected by third party systems rejecting communications due to the absence of a lead ID. Whilst lead referrals by emails were successful, they may not have included the lead ID.

We’re really sorry for the disruption caused.
Posted Aug 21, 2020 - 20:44 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2020 - 19:43 BST
Update
We are continuing to investigate this issue.
Posted Aug 21, 2020 - 17:05 BST
Investigating
We're seeing an issue today when generating sub leads. You'll notice that you can't search for sub leads and when trying to access the details (or transactions tab) from a sub lead you'll see an error. We are just investigating the issue and will share more details here once we understand the problem. thanks for your patience whilst we investigate!
Posted Aug 21, 2020 - 17:05 BST