Jobs Queue - Degraded Performance
Incident Report for FLG
Resolved
All remaining jobs are now in progress. Apologies for today's delays and slow queues.
Posted Apr 10, 2014 - 16:44 BST
Update
Loads have returned to normal levels. Remaining import/update jobs will be released over the next hour. Thanks for bearing with us.
Posted Apr 10, 2014 - 16:05 BST
Update
We're holding lead import/update jobs back currently and will release them into queues for processing one by one shortly. This is helping us to manage load better.
Posted Apr 10, 2014 - 15:05 BST
Update
Leads are now showing up in (very near) real time again. Bulk action/webhook processing is still slower than usual or delayed. We're keeping a close eye on things.
Posted Apr 10, 2014 - 14:53 BST
Update
Load is still high, however the delay on incoming leads is now at ~10 minutes. Thanks for bearing with us.
Posted Apr 10, 2014 - 14:10 BST
Update
The load is easing off, but very slowly. Jobs are processing very slowly or queuing. New leads are currently delayed by ~20 minutes.
Posted Apr 10, 2014 - 13:29 BST
Monitoring
The queues are abnormally busy currently, and that seems to have had a big impact on performance. You'll notice jobs running slower than usual, and leads may be delayed showing up in your account (they may be received successfully, and then not show up in 'Search Leads').

Everything is working its way through and will show up soon. Load is now easing off. Thanks for being patient.
Posted Apr 10, 2014 - 12:59 BST
Investigating
We are currently investigating degraded performance to the processing of items through the jobs queue (for instance processing the queue of new leads into the database.) We'll update here as with further information shortly - restoring optimum performance is a very high priority.
Posted Apr 10, 2014 - 12:44 BST