No access to FLG Insights, FLG Journeys, FLG Appointments and FLG Voice
Incident Report for FLG
Resolved
This incident has been resolved.
Posted 28 days ago. Jul 20, 2019 - 16:58 BST
Investigating
We are currently investigating this issue.
Posted 28 days ago. Jul 20, 2019 - 16:12 BST
This incident affected: FLG and FLG Insights.