An Issue with Google Mail
Incident Report for FLG
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 14:38 GMT
Monitoring
We are currently able to access our emails and we'll be able to respond to your queries shortly
Posted Dec 14, 2020 - 13:07 GMT
Investigating
Like many businesses, we are currently affected by the Google service disruption. Google Mail is currently inaccessible and as such if you have emailed the support team (support@flgtechnology.co.uk) or a team member directly (****@flgtechnology.co.uk / ***@getflg.com), there may be a slight delay until we can access this inbox.
If you reply to an email we have sent you previously this will land in FLG where the team will be able to respond quicker.

We'll update as we follow Google's issues hopefully to confirm this is resolved !
Posted Dec 14, 2020 - 12:06 GMT