Import Leads. Using Tools > Import is creating duplicate leads
Incident Report for FLG
Resolved
This incident is now resolved. To confirm, the impact we saw here was for Importing leads only. Uploading a spreadsheet seemed to create multiple leads. This is now working correctly and you can now continue to upload your leads as usual. Sorry for the wait there!.
Posted Jun 03, 2020 - 10:22 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2020 - 10:09 BST
Investigating
We are currently investigating this issue.
Posted Jun 03, 2020 - 09:46 BST