Access to Insights Unavailable
Incident Report for FLG
Resolved
The problem was with one of our hosting providers. Access to Insights is now restored.
Posted 11 months ago. Dec 05, 2018 - 19:14 GMT
Investigating
We are currently investigating this issue.
Posted 11 months ago. Dec 05, 2018 - 16:44 GMT