FLG is down
Incident Report for FLG
Postmortem

We would like to apologise for the brief disruption to service on Friday 8th March. In the last month we have had 4 incidents, 2 of which were a slowing of the system related to the same issue and 1 minor outage that was resolved in 10 minutes. This most recent incident is unrelated to the others and lasted for just over an hour resulting from a malicious act against a third party provider that cascaded onto us.

We understand that after a relatively long period of no incidents, having 4 so close to each other may result in some frustration and inconvenience. In all cases we have resolved matters well within our SLA timescales; however, our ambition is to prevent rather than have to resolve issues. Our current solutions prevent a recurrence of this incident, but we will not stop there and have identified additional actions we can take to make our robust defences even more so. We will be communicating in more detail in the coming weeks about what has already been done in 2024 as well as our plans for the rest of the year in this space.

We are committed to mitigating risks and being fully responsive to potential disruptions. Our team is well-drilled in incident management and was able to reassure and provide information throughout these incidents. Thank you for your patience and we wish to assure you that we see all our customers as trusted partners we care about and wish to succeed. Thank you for taking the time to read this and we are available should you have any further queries.

Posted Mar 13, 2024 - 10:19 GMT

Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 14:48 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2024 - 09:56 GMT
Identified
We have identified the issue and are working towards a fix. We'll update the message in another 30 mins.
Posted Mar 08, 2024 - 09:35 GMT
Investigating
We are currently investigating this issue and will update this message in 30 minutes.
Posted Mar 08, 2024 - 08:31 GMT
This incident affected: Applications & API (Main Platform & API).