Error when trying to bulk contact leads

Incident Report for FLG

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 14:54 BST

Monitoring

We have successfully resolved the issue, and all systems are now operating as expected.

Thank you for your patience. If you experience any further issues, please reach out to our support team.
Posted Apr 03, 2025 - 13:45 BST

Investigating

We are aware of an issue affecting bulk contact functionality. Our team is actively investigating and working on a fix. We appreciate your patience and will provide updates as soon as possible.
Posted Apr 03, 2025 - 13:17 BST
This incident affected: Email & SMS (Outbound Email, Outbound SMS) and Applications & API (Main Platform & API).