System slowness
Incident Report for FLG
Resolved
System performance is now back to normal.
Posted May 17, 2022 - 10:43 BST
Investigating
We are receiving some reports of general system slowness.

Sorry for any problems this may be causing. This is being looked into as a top priority and we'll provide an update as soon as we can.
Posted May 17, 2022 - 09:23 BST
This incident affected: Processing & Workflow (Background Processing, Workflow Processing) and Applications & API (Main Platform & API, Keyword Search).