Flow XO access problems
Incident Report for FLG
Resolved
This incident has been resolved.
Posted 11 days ago. Apr 12, 2019 - 15:10 BST
Identified
The issue has been identified and a fix is being implemented.
Posted 11 days ago. Apr 12, 2019 - 13:46 BST
Investigating
We are currently investigating this issue.
Posted 11 days ago. Apr 12, 2019 - 12:05 BST
This incident affected: Flow XO.